Daily Archives: November 2, 2010

Best File Encryption Tool: TrueCrypt [Hive Five Followup]

Last week we asked you to share your favorite file encryption tool. We tallied up the votes and put the five top contenders before you in the Hive Five. Now we’re back to highlight the winner and runners-up. More »







Grab iPhone-Mounting Application Phone Disk Free Through Dec. 1 [Dealhacker]

Windows/Mac: Phone Disk mounts an iPhone, iPod touch, or iPad natively in Windows or Mac OS X, just like a removable USB drive. The developers have extended a free download period until Dec. 1, so snag it sooner rather than later. More »







A Valid Provisioning Profile For This Executable Was Not Found

Over the past few months I’ve been working on a mobile commerce/payment project where my focus is on the architecture and design side of things, sans coding. This past weekend I started a development project and all was going swimmingly until I received the error message shown in the post title.

As far as I could recall nothing had changed since the last time I was in development mode: Xcode was cooperating, a development provisioning profile was installed and the application identifier was properly set in the build properties.

After walking away for a few hours, upon returning the lightblulb came on – I recalled that within the past few months I purchased a new iPhone 4. Yes, it should of been obvious that I needed to upload the new device UDID and generate a new development provisioning profile, however, I’d been using the same device for quite some time and it was second nature to simply plug in my phone and install an app.

Although the message above is correct in that the provisioning profile was not valid, I may not of been sidetracked if there was a litt more detail provided, specifically: “A valid provisioning profile for this device was not found.” The takeaway for me with this (and most all error messages) is to read between the lines – at the highest level the information was correct, I just needed to think one level deeper to get to the crux of the problem.

I realize this post will apply to only a select few who run into a similar issue, yet hopefully it will save someone a few hours of debugging.

WP Like Button Plugin by Free WordPress Templates